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WISEstaff Reporting (Wisconsin)
(Human Resources)
Last Modified on 10/22/2022 9:57 am CDT

Report Logic | Report Editor | Assignment File Report Layout | Contract File Report Layout

PATH: Human Resources > Reports > WISEstaff Reporting

The WISEstaff Reporting tool provides data to complete the Assignment File extract and the
Contract File extract for WISEstaff Reporting. The Assignment File reports all staff with active or
future dated work assignments marked as WISEstaff Reported for the School Year as of the
Effective Date entered on the extract editor. The Contract File provides staff contract details to the
state for staff with an assignment type of 0 or 1. 

WiseStaff Reporting Editor Example

Report Logic
PATH: Human Resources > Reports > WISEstaff Reporting

Assignment File
The Assignment File reports staff with active or future dated work assignments marked as
WISEstaff Reported for the School Year as of the Effective Date entered on the extract editor
and Assignment File records saved on the State Reporting tool.

Report records are different depending on the Format you you choose on the extract editor.

CSV (State Format)  : Reports all records for staff members with active OR future
dated Work Assignments for the School Year marked as WISEstaff Reported on the
Position Code when there is at least one Work Location (Working School Number) with at

http://infinite-campus-oct-22.knowledgeowl.com/#report-logic
http://infinite-campus-oct-22.knowledgeowl.com/#report-editor
http://infinite-campus-oct-22.knowledgeowl.com/#assignment-file-report-layout
http://infinite-campus-oct-22.knowledgeowl.com/#contract-file-report-layout
https://dyzz9obi78pm5.cloudfront.net/app/image/id/5eb6075f8e121c3510ea170b/n/WiseStaff%20Reporting%20Editor.png
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least one WISEstaff Area Code saved on the State Reporting tab.

Excel/HTML: Use the Excel format for troubleshooting or to audit Assignment File data
prior to submission. The Excel format will report all staff with an active Work Assignment
record as of the Effective Date.

Multiple records can report for staff members with multiple active assignments.

Contract File
All staff with active or future dated work assignments for the School Year as of the Effective
Date (selected on the extract editor) are selected for reporting. Work Assignments with end
dates prior to the Effective Date are not included.
Staff with an Assignment Type in 0 or 1 report with the Contract File Record details for the
School Year selected in the report parameters.
Staff with only Assignment Types in 2, 3 or 4 report without Contract File Record details.

Report Editor
PATH: Human Resources > Reports > WISEstaff Reporting

Field Description

Extract Type Assignment File
Contract File

Effective Date This date determines which staff to report. All staff with active or future
dated work assignments as of this date are reported.

School Year Contract File Only
This date determines which staff to report and which Contract File records
are selected. 
All staff with active or future dated work assignments for the School Year
as of the Effective Date report.

Local
Assignment ID
Options

Leave Blank
Personnel Number

Format CSV (State Format)
Excel
HTML

Generate
Extract

The report can be created immediately using the Generate Extract
button.
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Assignment File Report Layout
PATH: Human Resources > Reports > WISEstaff Reporting > Extract Type > Assignment File

Data Element Description Type,
Format, and
Length

Campus
Application

The following columns appear at the beginning of the Excel file only.
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 Warnings  Excel Format Only 
This column provides warning messages
for staff records that are missing in part
or whole from the CSV (State Reported)
format. Warnings report for any staff
with an active or future dated Work
Assignment as of the Effective Date
selected in the report parameters who 

do not report as staff on the CSV
(State Format) at all as a result of
all their Work Assignments being
impacted by one or more of the
warnings listed below.
have at least one Work Assignment
record where the Position Code is
NOT marked as WISEstaff
Reported. This includes

Work Assignments with
previously saved Assignment
File records on the State
Reporting tab.
Work Assignments without
any previously saved
Assignment File records on
the State Reporting tab.

have a Work Assignment missing a
WISEstaff Position Code.
have a Work Assignment where a
WISEstaff Position Code was
changed after Assignment File
records were saved on the State
Reporting tab.
have a Work Assignment missing a
WISEstaff Area Code on a Work
Location (Working School Number).
are missing the required WISEid
(Human Resources > Personnel >
Personnel Master > HR General
Information (Current Record) >
State Number) for reporting on the
Assignment File.

N/A N/A

Data Element Description Type,
Format, and
Length

Campus
Application
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Errors  Excel Format Only 
This column provides error messages
for staff records that are present on the
CSV (State Reported) format but
districts may want to review for missing
data in fields or for data in fields that
exceeds expected values.
Errors include any staff Assignment File
records where

Grade Levels values are missing
and are reportable based on the
Assignment View logic.
WISEstaff FTE values are missing
and are reportable based on the
Assignment View logic.
WISEstaff FTE value(s) entered
exceed 1.00.

The sum for all Work
Assignments > 1.00.
The sum for a single Work
Assignment > 1.00.

N/A N/A

Last Name  Excel Format Only 
The staff member's last name.

Alphanumeric Human
Resources >
Personnel >
Personnel
Master > Person
> HR General
Information >
Last Name

First Name  Excel Format Only 
The staff member's first name.

Alphanumeric Human
Resources >
Personnel >
Personnel
Master > Person
> HR General
Information >
First Name

Data Element Description Type,
Format, and
Length

Campus
Application
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Assignment
Type

 Excel Format Only 
The Assignment Type that corresponds
with the WISEstaff Position
Code/WISEstaff Area Code.

0: Professional - Special Education
1: Professional - Regular Education
2: Short-Term Substitute/Extra
Curricular Activities
3: Support - Regular Education
4: Support - Special Education

Numeric Human
Resources >
Personnel >
Personnel
Master > State
Reporting

The following columns appear in all format types.

Local
Assignment ID

A local assignment ID for this record.
Unique field to be used by your agency
for verification purposes to make sure
DPI uses the correct local staff record.

Alphanumeric Human
Resources >
Personnel >
Personnel
Master > HR
General
Information >
Personnel
Number

WISEid A unique, permanent identifier for
people in the education system in the
State of Wisconsin.

Numeric, 10
digits

Human
Resources >
Personnel >
Personnel
Master > HR
General
Information
(Current
Record) > State
Number

Data Element Description Type,
Format, and
Length

Campus
Application
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Working LEA
Number

T he valid DPI-assigned LEA number of
the education agency. 
This column may report from one of the
following areas.

System Administration >
Resources > District Information >
District Detail > State District
Number
AND
Human Resources > Personnel >
Personnel Master > State
Reporting > Assignment File >
Working LEA

OR
Human Resources > Administration
> HR Codes > Personnel > 
Override LEA
AND
Human Resources > Personnel >
Personnel Master > State
Reporting > Assignment File >
Override Working LEA

Numeric, 4
digits

See Description

Position Code The Position Code that corresponds with
the staff member's job assignment.

Numeric, 2
digits

Human
Resources >
Personnel >
Personnel
Master > Work
Assignment >
WISEstaff
Position Code
OR
Human
Resources >
Administration >
Position Code >
Position Code
Detail >
WISEstaff
Position Code

Data Element Description Type,
Format, and
Length

Campus
Application
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Area Code The staff member's general realm of
assignment and related work
subject/tasks.

Numeric, 4
digits

Human
Resources >
Personnel >
Personnel
Master > State
Reporting >
Assignment File
> WISEstaff Area
Code

Hiring LEA
Number

T he valid DPI-assigned LEA number of
the education agency. 

Numeric, 4
digits

System
Administration >
Resources >
District
Information >
District Detail >
State District
Number
OR
Human
Resources >
Administration >
District Master >
State District
Number

FTE The amount of work a staff member will
complete at a particular agency in a
school year.
 The FTE entered for each WISEstaff
Area Code field set reports.  
 If a  WISEstaff FTE is not entered for an
Assignment Type, this column reports
blank in the CSV file.

Numeric, 3
digits
N.NN

Human
Resources >
Personnel >
Personnel
Master > State
Reporting >
Assignment File
> Work
Assignment >
Work Location
(Working School
Number) >
WISEstaff FTE

Data Element Description Type,
Format, and
Length

Campus
Application



Copyright © 2021 Infinite Campus. All rights reserved.

Bilingual
Program      
     

Identifies whether the staff member
teaches in a state or locally-funded
bilingual education program.

Alphanumeric
Y or N

Human
Resources >
Personnel >
Personnel
Master > State
Reporting >
Assignment File
> Work
Assignment >
Work Location
(Working School
Number)
> Bilingual
Program

Working
School
Number

The DPI-assigned school number where
the staff member's  assignment is
performed. 

Numeric, 4
digits

Human
Resources >
Personnel >
Personnel
Master > State
Reporting >
Assignment File
> Work
Assignment >
Work Location
(Working School
Number)  

Long Term
Sub            

Identifies whether the assignment is
performed by a long-term substitute
(assignment over 45 days).

Alphanumeric
Y or N

Human
Resources >
Personnel >
Personnel
Master > State
Reporting >
Assignment File
> Work
Assignment >
Work Location
(Working School
Number) > Long
Term Substitute

Data Element Description Type,
Format, and
Length

Campus
Application
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School Board
Approved
Alternative
Educational
Program      
     

Identifies whether the assignment is
part of an approved alternative
education program.

Alphanumeric
Y or N

Human
Resources >
Personnel >
Personnel
Master > State
Reporting >
Assignment File
> Work
Assignment >
Work Location
(Working School
Number)
> School Board
Approved
Education
Program

Subcontracted
though a
Contracted
Agency

Identifies whether the staff member is
hired as a subcontractor for the
assignment.

Alphanumeric
Y or N

Human
Resources >
Personnel >
Personnel
Master > State
Reporting >
Assignment File
> Work
Assignment >
Work Location
(Working School
Number)
> Subcontracted
From Agency

Data Element Description Type,
Format, and
Length

Campus
Application
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Grade Levels  
         

Identifies  all course levels performed by
teaching staff for an assignment and
doesn't necessarily coordinate to the
students' grade levels.
  If  Grade Level values are not entered
for an applicable Assignment Type, this
column reports blank in the CSV file.

Numeric System
Administration >
Resources >
Grade Level
Definitions >
Grade Level
Definitions
Editor
Human
Resources >
Personnel >
Personnel
Master > State
Reporting >
Assignment File
> Work
Assignment >
Work Location
(Working School
Number)
> Grade Levels

School Year  
         

The current school year. Numeric
YYYY

Human
Resources >
Reports >
WISEstaff
Reporting >
Effective Date

Local Use      
     

Optional field used for anything districts
would like to add about the staff
member.

Alphanumeric,
100
Characters

Human
Resources >
Personnel >
Personnel
Master > State
Reporting >
Assignment File
> Work
Assignment >
Work Location
(Working School
Number) > Local
Use

Data Element Description Type,
Format, and
Length

Campus
Application
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Local
Assignment
Title   

The staff member's assignment title as
it's known at that particular location.

Alphanumeric,
255
characters

Human
Resources >
Personnel >
Personnel
Master > State
Reporting >
Assignment File
> Work
Assignment >
Work Location
(Working School
Number) > Local
Assignment Title

Data Element Description Type,
Format, and
Length

Campus
Application

Contract File Report Layout
PATH: Human Resources > Reports > WISEstaff Reporting > Extract Type > Contract File

Data
Element

Description Type,
Format, and
Length

Campus
Application

The following columns appear at the beginning of the Excel file only.
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 Warnings  Excel Format Only 
This column provides warning messages for
staff records that are missing in part or whole
from the CSV (State Reported) format.
Warnings report for any staff with an active or
future dated Work Assignment as of the
Effective Date selected in the report
parameters who

do not report as staff on the CSV (State
Format) at all as a result of all their Work
Assignments being impacted by one or
more of the warnings listed below.
have at least one Work Assignment
record where the Position Code is NOT
marked as WISEstaff Reported. This
includes

Work Assignments with previously
saved Assignment File records on
the State Reporting tab.
Work Assignments without any
previously saved Assignment File
records on the State Reporting tab.
have a Work Assignment missing a
WISEstaff Position Code.
have a Work Assignment where a
WISEstaff Position Code was
changed after Assignment File
records were saved on the State
Reporting tab.
have a Work Assignment missing a
WISEstaff Area Code on a Work
Location (Working School Number).

will report demographics only on the CSV
(State Format) as a result of having a
current Assignment File record with an
Assignment Type in 0 or 1 but are
MISSING a saved Contract File Record for
the School Year being reported so no
details are on the report.
are missing the required WISEid (Human
Resources > Personnel > Personnel
Master > HR General Information (Current
Record) > State Number) for reporting on
the Assignment File.

N/A N/A

Data
Element

Description Type,
Format, and
Length

Campus
Application
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 Errors  Excel Format Only 
Staff with current Assignment File record with
an Assignment Type in 0 or 1 and a Contract
File Record for the School Year who are
reporting with missing values or incorrect
values.

Contract Salary reporting as 0.00
Contract Fringe Benefits reporting as 0.00
Contract Days reporting as 0.
Missing Highest Degree record in
Qualifications
Contract Salary amount exceeds 6 digits.
Contract Fringe Benefits amount exceeds
6 digits.

N/A N/A

The following columns appear in all format types.

WISEid A unique, permanent identifier for people in
the education system in the State of
Wisconsin.

Numeric, 10
digits

Human
Resources >
Personnel >
Personnel
Master > HR
General
Information
(Current
Record) >
State Number

Hiring LEA
Number

The valid DPI-assigned LEA number of the
education agency. 
This column may report from  System
Administration > Resources > District
Information > District Detail > State District
Number.

Numeric, 4
digits

See
Description

Last Name The staff member's last name. Alphanumeric,
50 characters

Human
Resources >
Personnel >
Personnel
Master >
Person > HR G
eneral
Information >
Last Name

Data
Element

Description Type,
Format, and
Length

Campus
Application
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First Name The staff member's first name. Alphanumeric,
50 characters

Human
Resources >
Personnel >
Personnel
Master >
Person > HR
General
Information >
First Name

Highest
Degree

The highest level of education the staff
member has attained.
This column reports when a staff member has
one or more active WISEstaff Position Code/
WISEstaff Area Codes combinations where the
Assignment Type = 0 or 1.
The highest degree reports. Degrees are
ranked in the following order:

Rank Description Code

1 Other 08

2 Associate 03

3 Bachelor's 04

4 Master's 05

5 6 - Year Specialist's 06

6 Doctorate 07

Numeric,, 2
digits

Human
Resources >
Personnel >
Personnel
Master >
Qualifications
> Education >
Degree Type

School
Year

The school year selected in the report
parameters.

Numeric
YYYY

System
Administration
> Calendar >
School Years
> School Year
Editor > End
Year

Data
Element

Description Type,
Format, and
Length

Campus
Application
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Local
Years
Experience

The number of years the staff member was
employed by an educational agency down to
the nearest half-year.

Numeric
NN.N

Human
Resources >
Personnel >
Personnel
Master >
State
Reporting >
Contract File
> School Year
> Local Years
or Override
Local Years

Total
Years
Experience

The number of years the staff member worked
at any educational agency down to the nearest
half-year including the current school year.

Numeric
NN.N

Human
Resources >
Personnel >
Personnel
Master >
State
Reporting >
Contract File
> School Year
> Total Years
or Override
Total Years

Contract
Salary

The amount of money specifically cited in the
regular contract between the staff member
and the hiring LEA.

Numeric, 6
digits

Human
Resources >
Personnel >
Personnel
Master >
State
Reporting >
Contract File
> School Year
> Contract
Salary

Data
Element

Description Type,
Format, and
Length

Campus
Application
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Contract
Fringe
Benefits

Total of all of the following items under Object
Code 200 Employee Benefits in the WUFAR
Handbook: 210 Retirement, 220 Social
Security, 230 Life Insurance, 240 Health
Insurance, 250 Other Employee Insurance, and
290 Other Employment Benefits, including
cash payments in lieu of benefits.

Numeric, 6
digits

Human
Resources >
Personnel >
Personnel
Master >
State
Reporting >
Contract File
> School Year
> Contract
Fringe
Benefits

Final
Salary
Code

The code that coordinates with the staff
member's final salary as reported by the
agency.
Y or N report when there is a Contract for the
person. This code indicates whether contract
information is finalized for the year.  If the
contract is still in negotiation, then N reports.
This column reports blank when the field does
not apply to a specific assignment area and
position code combination.

Alphanumeric
Y or N

Human
Resources >
Personnel >
Personnel
Master >
State
Reporting >
Contract File
> School Year
> Final Salary
Code

Contract
Days

The number of days a staff member is
contracted to work for an agency.

Numeric, 3
digits

Human
Resources >
Personnel >
Personnel
Master >
State
Reporting
> Contract
File > School
Year >
Contract Days

Data
Element

Description Type,
Format, and
Length

Campus
Application
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Local Use Optional field used for anything districts would
like to add about the staff member.

Alphanumeric,
50 Characters

Human
Resources >
Personnel >
Personnel
Master >
State
Reporting >
Assignment
File > Work
Assignment >
Work Location
(Working
School
Number)
> Local Use

Local ID Unique field used by an agency for verification
purposes to make sure DPI uses the correct
local staff contract record.

Numeric, 50
characters

Field reports
as blank
OR
Human
Resources >
Personnel >
Personnel
Master > HR
General
Information
(Current
Record) >
Personnel
Number

Gender The staff member's gender. Alphanumeric,
M or F

Human
Resources >
Personnel >
Personnel
Master > HR
General
Information
(Current
Record) >
Gender

Data
Element

Description Type,
Format, and
Length

Campus
Application
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Year of
Birth

The year in which the staff member was born. Numeric
YYYY

Human
Resources >
Personnel >
Personnel
Master > HR
General
Information
(Current
Record) >
Birth Date >
Year only

Former
Last Name

Reports blank. N/A N/A

Race Key The code that represents the racial/ethnic
group or groups with which the person
identifies.

Numeric, 4
digits

Attribute
location:
System
Administration
> Custom >
Attribute/
Dictionary >
Identity >
Race Ethnicity
Code Mapping

Data
Element

Description Type,
Format, and
Length

Campus
Application


